解决sablog1.6x 后台在Chrome下不支持富文本编辑器

 sablog1.6x 后台在Chrome无法加载FCK文本编辑器,做了些小修改,

修改admin/editor/fckeditor_php4.php,和admin/editor/fckeditor_php5.php,找到IsCompatible()函数,加入以下代码:

  1.         else ifstrpos($sAgent,‘Chrome’)!==false){  
  2.             return true;  
  3.         }  

 

PHP代码
  1. function IsCompatible()  
  2.     {  
  3.         global $HTTP_USER_AGENT ;  
  4.   
  5.         if ( isset( $HTTP_USER_AGENT ) )  
  6.             $sAgent = $HTTP_USER_AGENT ;  
  7.         else  
  8.             $sAgent = $_SERVER[‘HTTP_USER_AGENT’] ;  
  9.   
  10.         if ( strpos($sAgent‘MSIE’) !== false && strpos($sAgent‘mac’) === false && strpos($sAgent‘Opera’) === false )  
  11.         {  
  12.             $iVersion = (float)substr($sAgentstrpos($sAgent‘MSIE’) + 5, 3) ;  
  13.             return ($iVersion >= 5.5) ;  
  14.         }  
  15.         else if ( strpos($sAgent‘Gecko/’) !== false )  
  16.         {  
  17.             $iVersion = (int)substr($sAgentstrpos($sAgent‘Gecko/’) + 6, 8) ;  
  18.             return ($iVersion >= 20030210) ;  
  19.         }  
  20.         /*添加的代码*/  
  21.         else ifstrpos($sAgent,‘Chrome’)!==false){  
  22.             return true;  
  23.         }  
  24.         /*添加的代码结束*/  
  25.         else  
  26.             return false ;  
  27.     }  

 



发表评论

电子邮件地址不会被公开。 必填项已用*标注

您可以使用这些HTML标签和属性: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>